SRC-2022-0010 : VMware Workspace ONE Access DBConnectionCheckController Cross-Site Request Forgery Vulnerability

CVE ID: CVE-2022-22959

CVSS Score: 8.8, (/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H)

Affected Vendors: VMWare

Affected Products: Workspace ONE Access, Identity Manager, vRealize Automation

Vulnerability Details: This vulnerability allows remote attackers to execute arbitrary code on affected installations of VMware Workspace ONE Access. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within DBConnectionCheckController class. The issue results from the implementation of the IgnoreCsrfHandling class. An attacker can leverage this vulnerability to execute code in the context of the horizon user.

Vendor Response:

VMWare has issued an update to correct this vulnerability. More details can be found at: https://www.vmware.com/security/advisories/VMSA-2022-0011.html

Disclosure Timeline:

  • 2022-02-25 – Sent to VMWare PSIRT

  • 2022-04-06 – Coordinated public release of advisory

Credit: This vulnerability was discovered by Steven Seeley (mr_me) of Qihoo 360 Vulnerability Research Institute