SRC-2021-0003 : Microsoft SharePoint Server SPSqlDataSource Information Disclosure Vulnerability (patch bypass)

CVE ID: CVE-2021-24071

CVSS Score: 5.3, (/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N/E:P/RL:O/RC:C)

Affected Vendors: Microsoft

Affected Products: Microsoft SharePoint Server

Vulnerability Details:

This vulnerability allows remote attackers to disclose sensitive information on affected installations of SharePoint Server. Authentication is required to exploit this vulnerability.

The specific flaw exists within the SPSqlDataSource class. The issue results from the lack of proper validation of the user-supplied ConnectionString property. In some cases, an attacker can leverage this vulnerability to disclose files in the context of the Administrator.

Vendor Response:

Microsoft has issued an update to correct this vulnerability. More details can be found at: https://msrc.microsoft.com/update-guide/vulnerability/CVE-2021-24071

Disclosure Timeline:

  • 2020-12-09 – Sent to Microsoft

  • 2021-02-09 – Coordinated public release of advisory

Credit: This vulnerability was discovered by Steven Seeley (mr_me) of Qihoo 360 Vulcan Team