SRC-2020-0017 : Foxit Reader Heap Buffer Overflow Remote Code Execution vulnerability

CVE ID:

CVE-2020-12248

CVSS Score:

7.8, (AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H)

Affected Vendors:

Foxit

Affected Products:

Foxit Reader

Vulnerability Details:

This vulnerability allows remote attackers to execute arbitrary code on affected installations of Foxit Reader. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the processing of image resources inside of PDF files. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length heap-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process.

Vendor Response:

Foxit has issued an update to correct this vulnerability. More details can be found at:
https://www.foxitsoftware.com/support/security-bulletins.html

Disclosure Timeline:

  • 2020-04-35 – Sent to and verified by Foxit
  • 2020-07-31 – Coordinated public release of advisory

Credit:

This vulnerability was discovered by Steven Seeley of Qihoo 360 Vulcan Team