SRC-2015-0003 : Oracle Endeca Tools and Frameworks AMF Request Beanshell Script Remote Code Execution Vulnerability

CVE ID:

CVE-2015-2653

CVSS Score:

6.4, (AV:N/AC:L/Au:N/C:P/I:P/A:N)

Affected Vendors:

Oracle

Affected Products:

Versions 3.1.1, 3.1.2, 11.0, 11.1 of the following products are confirmed vulnerable:

  • Oracle Commerce Guided Search
  • Oracle Commerce Experience Manager
  • Oracle Endeca Tools and Framework

Vulnerability Details:

This vulnerability allows remote attackers to execute arbitrary code via a crafted ActionScript Message Format (AMF) request. Authentication is required but a known authentication bypass exists (SRC-2015-0002). When creating a 'datastore' within the Content Acquisition System (CAS) interface, the application accepts an arbitrary beanshell script that will execute on the Endeca Tools and Frameworks installation, under the context of the "endeca" user.

Vendor Response:

Oracle has issued an update to correct this vulnerability. More details can be found at: http://www.oracle.com/technetwork/topics/security/cpujul2015-2367936.html

Disclosure Timeline:

  • 2015-02-01 – Verified and sold to Beyond Security
  • 2015-06-14 – Coordinated public release of advisory

Credit:

This vulnerability was discovered by Steven Seeley of Source Incite

Acknowledgments:

Source Incite would like to acknowledge Beyond Security’s SSD program for the help with co-ordination of this vulnerability. For more information you can view a technical blog post related to the vulnerability at https://blogs.securiteam.com/index.php/archives/2511.